Resolved
SDK version 0.25.0+ is required to use Tinker API.
Monitoring
Training requests where loss_fn_inputs tensors have different shapes across datums in one batch (for example, per-datum target_tokens with a varying second dimension) are now fully supported on thinkingmachines/Inkling. Supporting this required a change to both the server and the SDK, so please upgrade to Tinker SDK 0.24.1 or later (pip install -U tinker).
On SDK versions 0.24.0 and earlier, these requests are rejected at submission with: loss_fn_inputs tensors have different shapes across datums (past the first dimension), which requires tinker SDK >= 0.24.1 to decode the response. Please upgrade your Tinker SDK.
Upgrading resolves this. All other workloads are unaffected and require no action.