Resolved
SDK version 0.25.0+ is required to use Tinker API.
Monitoring
The new Tinker SDK version 0.23.3 has been pushed. Please update your SDK if you are running into this issue.
Identified
We confirmed that this is triggered by a new pyqwest version (0.7.0). As a mitigation you can pin to an older version (e.g. 0.6.2). We are working on releasing a Tinker SDK version with a patch.
Investigating
Tinker SDK calls may be getting stuck. Eventually they fail with errors like client error (Connect): invalid peer certificate: UnknownIssuer . This problem has been observed primarily on MacOS.